GeoNames Home | Postal Codes | Download / Webservice | About 

GeoNames Forum
  [Search] Search   [Recent Topics] Recent Topics   [Groups] Back to home page 
[Register] Register / 
[Login] Login 
[Web Service] Slow response for the first search  XML
Forum Index -> General
Author Message
Anonymous



Hi,

I would have to get your mind about a low answer time when I search in geonames web service only the first time.

Indeed, I'm developping a webmapping interface using Cartoweb and I use the search in Geonames in order to "zoom" on an area of interest (AOI).
Everything is working, but I don't understand why the first search is always very slow... and sometimes no response...

I would like you to check on my web interface just to have a look on
this problem and maybe to tell me what to do to optimize my first
search...

The url is http://dev.sandre.eaufrance.fr/ogcviewer/ then go on the window tab, on the right, called 'AOI' (for Area of Interest). Then
you can perform a search as you perform in Geonames (the search is
only for these country : France, Martinique, Guadeloupe, French Guyana,
Reunion)

Any idea about this trouble??? any suggestion?

Thanks for your help.

Mathieu C.
marc



Joined: 08/12/2005 07:39:47
Messages: 4271
Offline

Hi Mathieu

The search service has currently an average response time of 145 ms for
the last 50'000 requests. I will improve the logging to better log long
running requests, and I will come back to you as soon as I know more.

What I see is you are always calling the service with maxRows=1000. This
definitely slows down the service. If you don't need so many rows, set
maxRows to the largest number of rows you really need.

Marc

[WWW]
 
Forum Index -> General
Go to:   
Powered by JForum 2.1.5 © JForum Team